
Using Excel to 
Troubleshoot EMIS Data



The Ohio Department of Education funds development of EMIS training materials 
as part of the EMIS Alliance grant. There is an expectation that ITCs will utilize these 
materials in training provided to your districts. That said, there are restrictions on 
use of the EMIS Alliance materials as follows: Materials developed as part of the 
EMIS Alliance program must be provided at no cost to your training participants. If 
you utilize the EMIS Alliance training materials – in whole or in part – you must not
charge participants a fee to attend the class where the materials are used. Likewise, 
you may not use the materials or any portion thereof in any event where a fee is 
charged to attend. Exceptions must be approved in writing by the Department of 
Education in advance of scheduling/promoting any event which may violate these 
restrictions.

Questions regarding appropriate use of EMIS Alliance materials, or requests for 
exception to the restrictions noted above, should be directed to Melissa Hennon 
[Melissa.Hennon@education.ohio.gov].
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Overview

• Basic Excel techniques can be used to analyze EMIS data 
from Student Information Systems (SISs), from the Data 
Collector, and on ODE EMIS reports

• This session will demonstrate Excel functions and practical 
applications that can be helpful in all phases of the EMIS 
data review process 
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Outline

• Simple formulas to troubleshoot student FTEs

• VLOOKUP to add LEA names to a report 

• Macro to format an FTE Detail report 

• Concatenation and conditional formatting to verify 
calendar data and student data 
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Use Simple Formulas to 
Troubleshoot Student FTEs
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Simple Formulas 

• In this section we are going to use simple formulas to 
identify differences between 
• Original FTEs and Adjusted FTEs

• Adjusted FTEs and Special Education Adjusted FTEs 

• We will filter and highlight those differences to aid in 
troubleshooting the FTE Detail report
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FTE Detail Report 
Open the most recent version of the FTE Detail Report 

7

1. Add two new columns 
by selecting column S 
and column T, then right 
click and select “Insert”

Do not format/prepare the report 

2. Drag to widen, then name 
the two new columns



Add Simple Formulas
Subtract ADJSTD FTE from ORIG FTE 
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In cell S2 type an equal sign 
then click into cell P2. Type 
a minus sign. Click into cell Q2 
and press enter

Double click, or click and drag the 
bottom right corner of cell S2 to 
populate the cells below

Here we can see if there is a difference 
between the original and adjusted FTE



Add Simple Formulas, cont’d
Subtract ADJSTD SPECED from ADJSTD FTE
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1. In cell T2 type an equal sign 
then click into cell Q2. Type 
a minus sign. Click into cell R2 
and press enter

2. Double click, or click and drag 
the bottom right corner of cell
S2 to populate the cells below

Here we can see if there is a difference 
between the adjusted FTE and adjusted 
special education FTE



Filter and Highlight ORIG vs ADJ Data 
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From the Data tab, add filters 

Filter on column S, 
“ORIG vs ADJ”, unselect 
“0” and click OK



Filter and Highlight ORIG vs ADJ Data, cont’d
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Select cells in column S “ORIG vs ADJ”, 
right click and highlight in yellow

Note that the appearance of 
IE-06 happens when the 
difference is 0.000001. This 
can be corrected by formatting
the column to be “Custom” with 
a value of “0.000000”



Filter and Highlight ADJ vs Sp Ed Data 
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From the Data tab, clear filters

Select filter in column 
“DISAB CNDTN CODE”, 
unselect “**” and “(Blanks)”
then click “OK” 



Filter and Highlight ADJ vs Sp Ed Data, cont’d 
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Apply a second filter on column
T, “ADJ vs Sp Ed”, then unselect 
“0”, and click “OK”



Filter and Highlight ADJ vs Sp Ed Data, cont’d 
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Select cells in column T, right 
click and highlight in green



Remove Filters, View Highlighted Cells, and Save
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From the Data tab click on “Filter” 
to remove all filters from the report 

Notice that the highlighted cells are
showing the amount of Original FTE (yellow) 
and Special Education weighted FTE (green)
that is not being funded

Investigate if the FTE is fundable and if there is 
an appropriate corrective action. Refer to the FTE 
Adjustment report for Result Codes



Quick Check • Are you able to add columns and 
perform simple formulas? 

• Are you able to filter and highlight 
adjusted values that should be 
investigated? 

• Are you looking at the FTE Adjustment 
report to identify the causes of the 
adjustments? 

Focusing on differences in 
original FTEs, adjusted FTEs, 
and special education 
adjusted FTEs can aid in 
troubleshooting FTE report 
data. Since many FTE Detail 
reports are quite large, 
highlighting can make the 
effected FTEs more obvious.
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Use VLOOKUP to add LEA Names 
from OEDS to a Report 
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Adding LEA Names 

• Most EMIS reports contain IRNs and no LEA names which can make 
troubleshooting difficult 

• This section will add LEA names to the FTE Detail report for a more 
user friendly outcome

• We will begin by running a report of LEA IRNs and names from OEDS 
and will perform a VLOOKUP to add the LEA names to the FTE Detail 
report
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Use OEDS Data to Create a Source File

https://oeds.ode.state.oh.us/SearchOrg

LEA data can be pulled into Excel using the OEDS Data link 
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Select LEA Types

Select District LEA Types to Include
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Selected District LEA 
types will appear here 



Select School LEA Types

Select School LEA Types to Include
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Selected School LEA 
types will appear here 



Select More LEA Types and Generate Report 

22

Click on “Generate Report”

Educational Service Center 

State Supported Organization 
State Supported School 
Developmental Disabilities 
Organization

Scholarship Provider 
Unclassified OEC Service Provider



Prepare the Source File 

Delete the top row

23

Select the top row, right 
click, and select “delete”



Sort Both Files 
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2. From the Data tab, choose Sort

3. In the Sort prompt, sort 
by IRN and click OK. If a sort
warning appears, click OK

1. Select all data on the report by 
clicking on the triangle between 
row 1 and column A or use CTRL A

4. Repeat this sort on the LEA IRN
column on the FTE Detail Report



Adding LEA Names to FTE Detail Report 
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1. Select the column to the right of 
the LEA IRN column, right click 
and select “Insert”. Label the 
new column “LEA Name”

2. Place cursor in the 
first open cell in the new 
column, then select the 
function icon



Begin the VLOOKUP
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Select VLOOKUP from the 
“Select a Function” list 
and click “OK” 

If VLOOKUP does not appear 
in the list of functions, search 
for VLOOKUP and select “Go” 



Build the VLOOKUP
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1. Be sure that your cursor is in 
the field next to “Lookup_value”

2. Select cell I2
in the “LEA IRN” 
column

3. See that I2 appears in 
the Lookup_value field

4. Place cursor in the 
Table_array field 



Build the VLOOKUP, cont’d
• Toggle to your OEDS Data spreadsheet and place your cursor in cell A2

• While holding down the Shift and CTRL keys at the same time, press 
right arrow then down arrow
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This will populate the Table_array field 

Place cursor into 
Col_Index_Num field



Build the VLOOKUP, cont’d
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To determine the Col_index_num 
count the number of columns from 
the left that contain the values we 
want to bring back from the OEDS file. 
In this case, column B is 2 columns 
from the left



Build the VLOOKUP, cont’d
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1. Insert 2 in the Col_index_num 
and FALSE in the Range_lookup

The complete VLOOKUP 
function appears here 

2. Note that the first match 
appears in the prompt

3. Click OK



View LEA Names then Save Changes
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Widen the LEA Name 
column as needed

See the first LEA Name appear, 
then double click or drag down 
to populate cells below

Before sending this report to others, change
the formulas in column J to values. Right click 
column J and choose “Copy”, then right click 
and paste values



Quick Check • Are you able to generate an LEA report 
from OEDS?

• Are you able to perform a VLOOKUP to 
add LEA names to the FTE Detail 
report?

• What other EMIS reports could be 
made more user friendly by populating 
LEA names into the report? 

Using data from OEDs to 
populate LEA names into an 
FTE Detail report can make 
the report easier to 
troubleshoot. Consider doing 
the VLOOKUP on other 
columns in the FTE Detail 
report or on other EMIS 
reports. 
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Create MACROs to Format 
Spreadsheets
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Create a Macro

• A macro can be created to complete spreadsheet set ups with 
one click

• Create it once and use it over and over

• Continue using the same FTE Detail Report that we have used 
in previous exercises 
• If you are using the same FTE Detail report from the last segment, 

remove filters before beginning the recording

• Note that we are not going to record the simple formulas exercise or 
the VLOOKUP to add LEA names
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Macro Steps 

• Freeze Top Row
• Wrap Text in the Header Row
• Justify column width
• Apply Filters
• Sort
• Subtotal then highlight subtotaled rows
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Begin Creating a Macro

From the View tab, select the down arrow under Macros and 
select “Record Macro”
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Select the down arrow

This begins 
the recording



Record Macro Prompt
Set up the prompt 
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Enter a Macro name or leave as the 
default value

Enter a unique Shortcut key value
Tip- enter a value that you don’t typically 
use as a Ctrl command (don’t use values 
such as Ctrl A, Ctrl C, Ctrl V, etc.)

Select “Personal Macro Workbook” 
from the “Store macro in” dropdown 
menu then click OK



Begin Recording the Macro

• Macro is now recording 

• Ready status and a small square icon show at bottom left
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Hovering over the icon will generate the message-
“A macro is currently recording. Click to stop recording.” 



Recording the Macro

Start by selecting the top row
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Click on the “1” to select the first row



Recording the Macro, cont’d

From the View tab, select “Freeze Panes” and “Freeze Top Row”
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Recording the Macro, cont’d

From the Home Tab, select “Wrap Text”
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Recording the Macro, cont’d
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Click on the triangle 
between Column A and
Row 1 to select the
entire spreadsheet

Place cursor between any 
two column headers and 
double click



Recording the Macro, cont’d

From the Home tab, select “Sort & Filter” and then “Filter” 
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Recording the Macro, New Steps
Sort by SSID, then by Enrollment Start Date
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From the Data Tab choose Sort 

Sort by SSID, then select “Add Level”, then 
sort by “ENRL START DATE”, then select 
“OK”

If a sort warning 
appears, click OK



Apply Subtotals
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From the Data Tab select Subtotal

In the Subtotal Prompt select
1. “At each change in:” SSID
2. “Use function:” Sum
3. “Add subtotal to:” ORIG FTE 
and ADJSTD FTE and ADJSTD 
SPECED CAT FTE
4. Select “OK”



Filter and Highlight
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1. Filter on the “RPT DIST IRN” 
column and select only “Blanks”
then click “OK”

2. From the Home Tab select 
highlight and choose a color

3. Choose the filter on the “RPT 
DIST IRN” column again and check 
“Select All” then click “OK”



Stop the Recording 

Click on the small square icon at the bottom left to stop the 
recording
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The appearance of the icon will change and a hover 
message will appear. “No macros are currently recording. 
Click to begin recording a new macro.”



Sorted, Subtotaled, and Highlighted Report
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Original FTEs, Adjusted FTEs, and Special 
Education FTEs, have been subtotaled 
and appear chronological order 



Make the Macro a Quick Link
Select the Quick Link dropdown 
arrow, then “More Commands” 
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In the “Choose commands 
from” dropdown, select “Macros”



Make the Macro a Quick Link
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The macro will move to the list on 
the right. While it is highlighted, 
select “Modify” and choose an icon

Select the macro 
and click “Add”

Click OK and OK



Quick Link
New Quick Link now appears 
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To remove the Quick Link, right click 
on the icon and select “Remove from 
Quick Access Toolbar” 



Save the Macro

• You can choose to save or not save your spreadsheet 

• A second prompt will ask if you want to save the changes 
made to your Personal Macro Workbook
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Select Save so that the macro will be 
available to use on future spreadsheets



Delete a Macro 

Once a Macro is created a few extra steps are needed to 
delete it if needed
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From a new or existing spreadsheet 
select “Unhide” from the View tab

In the Unhide prompt with 
PERSONAL.XLSB selected, click OK



Delete a Macro, cont’d
A blank spreadsheet named PERSONAL.XLSB will open 
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Select “Macros” from the View tab, then in the 
Macro prompt select the macro to be deleted 
select “delete”

IMPORTANT! When finished, close the Macro 
prompt and select “Hide” and the PERSONAL.XLSB will close



Quick Check • Are you able to record and save your 
macro? 

• Can you think of other instances where 
a macro can save time? 

• Are you able to find and manage your 
macros?

Macros are a quick way to 
turn a multi-step process in 
Excel into one click. Creating a 
quick link macro does not 
embed the macro into the 
spreadsheet. This macro is for 
use on the machine where it 
is created.
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Using Concatenation and 
Conditional Formatting to 
Verify Calendar Data and 

Student Data 
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Data Comparison

• Compare the Calendar Display report to the Student Attributes 
Effective Date Record (FD)

• Look for students who have no matching calendar in the calendar 
collection 

• Look for calendars being reported to EMIS that have no students 
assigned to them 

• Result will be cleaner data and correct calendar assignments on the 
FTE Detail report
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Calendar Display Report 
Find the Calendar Display report that aligns with the current student 
collection 

• In this example we will use the Final Calendar Collection for FY19 and 
compare it to the End of Year Student Collection for FY19

58

Select “View submission # Data” 
and find the Calendar Display
Report and the Student Attributes
Date Effective (FD) file



Prepare the Calendar Display Report 
• Run macro to prepare the report (original macro from FY19, 

not new subtotaling macro) or prepare the report manually

• Filter Row Number column to include only Row 1
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The result will be an unduplicated list of 
calendars that are being reported to EMIS



Prepare the Student Attributes (FD) Report 
Run macro to prepare the report (original macro from FY19, not 
new subtotaling macro) or prepare the report manually 
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Select the column to the right
of the Attendance Pattern column, 
then right click and select “insert” 



Concatenate Calendar Data

Name the new column (i.e. Calendar) and expand width of column
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2. If CONCATENATE does not appear 
in the list of functions, search 
for CONCATENATE and select “Go” 

3. Select CONCATENATE from 
the “Select a Function” list 
and click “OK” 

1. Place cursor into cell 
K2 then select the Insert 
Function Wizard



Concatenate Function Arguments
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Using the CONCATENATE Wizard, select the cells to include 

• Place cursor in Text1 field 
• then select cell A2

• In Text 2 enter a dash
• Place cursor in Text3 field 

• then select cell B2
• In Text4 enter a dash 
• Place cursor in Text5 field 

• then select cell I2

Click the down arrow 
to see more fields 



Concatenate Function Arguments, cont’d
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• In Text6 enter a dash 
• Place cursor in Text7 field 

• then select cell J2
• Click “OK”

Preview of results



Concatenated Calendar Data 
Data from all four cells is joined together with dashes in the 
same format at the data on the Calendar Display report
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Double click or drag to 
copy into cells below



Remove Duplicates 
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Select all data 

From the Data tab, select 
“Remove Duplicates”

From the Remove Duplicates 
prompt, click “Unselect All” and 
check the box for the column 
containing the concatenated data, 
then click “OK”



Duplicates Removed
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2. With duplicates removed, the report 
now contains an unduplicated list of 
calendars assigned to students 

1. Click OK 

3. Scroll to the bottom of the report 



Copy Data from Calendar Display Report 
Toggle to the Calendar Display report
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Select cells in Column A (not including 
the header row) then right click and 
select “copy”



Paste Data into Student Attributes (FD) Report
Toggle to the Student Attributes (FD) report 
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In the cell below the concatenated 
data column, paste the data from 
the Calendar Display report 



Conditional Formatting 
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Select column containing calendar 
data, then from the Home tab, select 
“Conditional Formatting”, “Highlight 
Cell Rules”, then “Duplicate Values” 



Conditional Formatting, cont’d
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Click OKDuplicate values will be 
highlighted in pink

Cells highlighted in pink 
indicate a matching calendar 
in the calendar collection for
calendar assigned to the 
student



Filter for Mismatches
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Click on the filter in the 
column containing 
concatenated data then 
select “Filter by Color”, 
then “No Fill”



Troubleshoot the data 
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Students without calendars
in the calendar collection 

Calendars with no students 
in the student collection 



Troubleshoot the data 
Why do students not have a matching calendar? 

• Is there something preventing a calendar from being reported, or is 
there no matching calendar being reported? 
• If yes, fix or create a matching calendar in the SIS and submit it to EMIS

• Is the student on a calendar that is not reportable to EMIS?
• If yes, ignore the mismatch

• Does the student match to a calendar based on a wildcard grade level? 
• Grade level ** in the calendar collection is a wildcard
• Example - District IRN-Building IRN-01-** matches to District IRN-Building IRN-

**-** 
• Match these students and calendars manually 

• Check your FTE Detail Report to verify that students are being correctly 
assigned to calendars through the calendar determination process
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Troubleshoot the data, cont’d

Why are there calendars with no students? 
• Typically okay to report calendars with no students just be careful 

if the unused calendar has a start date that is before your district’s 
earliest calendar or an end date that is after your latest calendar 
as this could effect some of the checks that EMIS uses such as 
separated staff and summer graduates 

• The early start date issue can be found for any calendar in the 
calendar collection whether it is used for students or not

• Consider not reporting unused calendars to EMIS 
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Quick Check • Are you able to perform concatenation 
and conditional formatting? 

• Do you have students with no calendar 
in the calendar collection? 

• Do you have calendars reported to 
EMIS with no students assigned? 

Calendar verification is very 
important since there are no 
checks in EMIS between the 
student collections and the 
calendar collections. This 
exercise will allow for a very 
quick comparison to identify 
EMIS reporting issues.

75



Summary

• Basic Excel techniques can be very useful when 
troubleshooting
• EMIS data in the Student Information System

• EMIS reports

• preview/review files 

• These techniques should be part of your everyday practices
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Resources

• Microsoft Excel Help within Excel “?” Articles and Videos

• Google it 

• Microsoft Excel Classes

• Your ITC
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Questions?


