
Using Excel to 
Troubleshoot EMIS Data



Overview

• Basic Excel techniques can be used to analyze EMIS data 
from Student Information Systems (SISs), from the Data 
Collector, and on ODE EMIS reports

• This session will demonstrate Excel functions and practical 
applications that can be helpful in all phases of the EMIS 
data review process 
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Outline

• Create a Macro to Format a Spreadsheet

• Calendar Data Verification

• Create a Dropdown List in Excel

• FTE Detail Report Subtotaling 
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Create a MACRO to Format a 
Spreadsheet
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Create a Macro

• A macro can be created to complete spreadsheet set ups 
with one click
• Freeze Top Row

• Wrap Text in the Header Row

• Justify column width

• Apply Filters

• Create it once and use it over and over

• Start by opening any FTE Report from the Data Collector
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Begin Creating a Macro

From the View tab, select the down arrow under Macros and 
select “Record Macro”
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Select the down arrow

This begins the recording



Record Macro Prompt
Set up the prompt 
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Enter a Macro name or leave as the 
default value

Enter a unique Shortcut key value
Tip- enter a value that you don’t typically 
use as a Ctrl command (don’t use values 
such as Ctrl A, Ctrl C, Ctrl V, etc.)

Select “Personal Macro Workbook” 
from the “Store macro in” dropdown 
menu then click OK



Recording the Macro

• Macro is now recording 

• Ready status and a small square icon show at bottom left
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Hovering over the icon will generate the message-
“A macro is currently recording.  Click to stop recording.” 



Recording the Macro, cont’d

Start by selecting the top row

9

Click on the “1” to select the first row



Recording the Macro, cont’d

From the View tab, select “Freeze Panes” and “Freeze Top Row”
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Recording the Macro, cont’d

From the Home Tab, select “Wrap Text”
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Recording the Macro, cont’d
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Click on the triangle 
between Column A and
Row 1 to select the
entire spreadsheet

Place cursor between any 
two column headers and 
double click



Recording the Macro, cont’d

From the Home tab, select “Sort & Filter” and then “Filter” 
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Stop the Recording 

Click on the small square icon at the bottom left to stop the 
recording
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The appearance of the icon will change and a hover 
message will appear. “No macros are currently recording. 
Click to begin recording a new macro.”



Make the Macro a Quick Link
Select the Quick Link dropdown 
arrow, then “More Commands” 
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In the “Choose commands 
from” dropdown, select “Macros”



Make the Macro a Quick Link
Highlight your macro from 
the list and click “Add”
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The macro will move to the list on the right. 
While it is highlighted, select “Modify” and 
choose an icon that you like.  Click Ok and Ok.



Quick Link
New Quick Link now appears 
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To remove the Quick Link, right click 
on the icon and select “Remove from 
Quick Access Toolbar” 



Save the Macro

• You can choose to save or not save your spreadsheet 

• A second prompt will ask if you want to save the changes 
made to your Personal Macro Workbook 
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Select Save so that the macro will be 
available to use on future spreadsheets



Delete a Macro 

Once a Macro is created a few extra steps are needed to 
delete it if needed

19

From a new or existing spreadsheet 
select “Unhide” from the View tab

In the Unhide prompt with 
PERSONAL.XLSB selected, click OK



Delete a Macro, cont’d
A blank spreadsheet named PERSONAL.XLSB will open 
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Select “Macros” from the View tab, then in the 
Macro prompt select the macro to be deleted 
select “delete”

When finished, close the Macro prompt and select 
“Hide” and the PERSONAL.XLSB will close



Quick Check • Are you able to record and save your 
macro? 

• Can you think of other instances where 
a macro can save time? 

• Are you able to find and manage your 
macros?

Macros are a quick way to 
turn a multi-step process in 
Excel into one click.  Creating 
a quick link macro does not 
embed the macro into the 
spreadsheet. This macro is for 
use on the machine where it 
is created.
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Calendar Data Verification
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Calendar Display Report & Exceptions
• Calendar Display Report

• Preview/Review report in the data collector

• Separate calendars for each unique combination of District IRN, 
Building IRN, Grade Level, and Attendance Pattern 

• Each day in session will display total student hours

• Exceptions will show attribute name with total student hours

• Using Excel, we can use this report to verify all exceptions 
have been entered
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Calendar Display Report
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From the Collection Request Tab, 
Calendar Collection, select “Preview 
Prepared Data” or “Submission data” 

Generate Preview/Review Data
Open Calendar_Display.csv



Format the Report
Prepare the report by running the macro we created in the last 
section, then remove filters
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Report Contents 
• Column A contains the calendar name, aka attendance pattern

• Column B contains the row number 
• The first 76 rows each contain one week on the calendar 

• Calendars can contain two additional rows for parent-teacher conference and 
professional development hours

• Column C contains the month and year

• Columns D-I contain the day of the week and the date of the month
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Formatting
• Column C is formatted to display the 

month and year only on the first row of 
the month

• We are going to fill this in for the rest of 
the rows to make it easier to read

• Select cell C2 

• Scroll to the very bottom the Column C

• Hold SHIFT and select the last cell in the 
report in column C
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Formatting, cont’d

• From the Home tab, 
click on “Find and 
Select”

• Choose “Go To 
Special”

• From the Go To 
Special prompt, click 
on the radio button 
for “Blanks” and 
then click OK
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Formatting, cont’d

• Your spreadsheet should show 
Column C as still highlighted, 
but the cells with actual data 
are not highlighted

• Make sure the sheet remains 
like this for the Fill-Down 
process to work correctly
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It is correct that 
cell C3 is blank



Formatting, cont’d
• Your cursor will be in cell C3, do 

not click into the cell

• Type an equal sign and then 
press the up Arrow Key 

• Hold down the Control (Ctrl) Key 
and press the Enter key

• This will fill in the blanks with 
the value found above it, so now 
every row will reflect the 
Month/Year on your Calendar
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Sort the Report 

• From the Data tab, 
select Sort

• Verify that “My 
Data has headers” 
is checked 

• Sort by Row 
Number and click 
OK
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Verify Exceptions cont’d 

• View the same row for each calendar type together 

• Verify all day values for all appropriate attendance patterns
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Quick Check • Are you able to download and prepare 
the Calendar Display Report? 

• Are you able to verify that every 
calendar day contains correct values 
across all of your calendars? 

• How often will you repeat this process 
throughout the year to verify that 
calendar data is being updated? 

Formatting and sorting the 
Calendar Display report can 
bring data issues to the 
surface.  Districts that have 
many calendars to maintain 
throughout the school year 
will find this process very 
effective in verifying that all 
calendar hours for each day 
are being reported correctly. 
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Create a Dropdown List in Excel

34



Gathering Data Using Excel
• Accurate and complete EMIS reporting starts with effective 

data gathering

• Providing district personnel a data collection form can improve 
data from the source

• Some examples of data collection processes
• Reading Diagnostic results 

• Score Not Reported reasons

• Staff Data 

• Retention Data 

• Graduation Data 
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Create a Data Collection Form
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In this example we will be creating a sheet for collecting reading 
diagnostic results 

• Open Excel and create a blank worksheet 

Click the Plus sign twice to 
generate two new sheets

Right click and choose “Rename” on all three tabs



Specify Dropdown Options
• Rename each sheet 

• Sheet 1 - Instructions
• Sheet 2 - Data Entry
• Sheet 3 - LOCKED

• Start with the “LOCKED” sheet, where we specify the 
dropdown options
• In Cell A1 Type: **
• In Cell A2 Type: AO
• In Cell A3 Type: NO
• In Cell A4 Type: RN
• In Cell A5 Type: EX
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Protect Drop Down Options

38

• Right click on the LOCKED Sheet name

• Choose “Protect Sheet…”

• Choose the top two options

• Specify a password if desired

• Click OK

• The sheet is now 

protected



Create Data Entry Sheet
Select the data entry sheet
• Enter the data to collect

• For this example we will create the following headers
• SSID
• Student Number
• Last, First
• Grade Level
• Building 
• Reading Diagnostic Result
• Notes: For your use only
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If desired, populate student data
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Generate an export from your SIS for the students and data you 
would like to collect the diagnostic result 

• Search Criteria example: All K-3 students with a district relationship 
of 1

• Export Fields example - SSID, Student Number, Last First, Grade Level, 
Building, Homeroom

Select the columns and rows of your spreadsheet



Format Data Collection
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With the cells on the spreadsheet selected

From the Home tab select, 
“Format as Table” button 
to choose a format to make 
for easier viewing

In the Format as Table 
Prompt, click OK



Format Data Collection
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Your data entry sheet should look something like this



Populate Drop-Down Options
Place your cursor in cell G2

• From the Data tab, choose “Data Validation”, and “Data Validation…” 
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Place cursor here first



Specify Drop-Down
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• From the Data Validation prompt, under “Allow”, select “List”

• For “Source:” first click your cursor into the prompt

• Next, navigate to the “LOCKED” sheet and select Cells A1-A5

• Click OK



Add Drop Down to all Cells
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• See the arrow appear when to the right of cell G2

• Click the arrow and the drop down options appear

• Drag the bottom right corner of the cell to populate the formula for every 
cell below G2 to the end of the list of students



Put the Workbook into use
• Use the “Instructions” sheet to direct data owners as to the 

correct way to complete the “Data Entry” sheet

• Save the workbook and distribute it to appropriate district 
data owners
• Be certain to include a deadline for data to be returned

• Use the completed workbook to update data in your SIS, and 
print for records

• Submit data to EMIS and return appropriate reports back to the data 
owner for verification
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Quick Check • What is the current data collection 
process in your district?

• Are you able to create pre-populated 
drop down lists?

• How could using drop down lists help 
you collect data?

Using an Excel spreadsheet 
can be a efficient way to 
collect data from district 
personnel.  By creating a 
spreadsheet with instructions 
and drop downs of valid 
options, data collected will be 
much more accurate and 
complete.
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FTE Detail Report Subtotaling 
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FTE Detail Report Subtotaling 
Subtotal the FTE Detail Report

• Sort by SSID, then by Enrollment Start Date
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From the Data Tab choose Sort 

Sort by SSID, then select “Add Level”, 
then sort by “ENRL START DATE”, then 
select “OK”



Sort Warning

This Sort Warning is generated because the ENRL START DATE column 
contains some numbers that are formatted as text
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If a Sort Warning is generated, 
leave as defaulted and select “OK”



Apply Subtotals
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From the Data Tab select Subtotal

In the Subtotal Prompt select
1. “At each change in:” SSID
2. “Use function:” Sum
3. “Add subtotal to:” ORIG FTE and 

ADJSTD FTE and ADJSTD SPECED 
CAT FTE

4. Select “OK”



FTE Detail Report Subtotaled
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This student’s Original FTE, Adjusted FTE, and Special 
Education FTE, have been subtotaled and 
appear chronological order 



Undo Subtotals
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To undo subtotals select “Subtotal” 
and then “Remove All” 



Quick Check • Are there students with Adjusted or 
Special Education FTEs that are less 
than the Original FTE?

• Are you using this report with your FTE 
Adjustment report to identify reasons 
for the adjustments? 

• Are you saving your reports between 
reviews? 

Subtotaling the FTE Detail 
Report provides a format for 
easier analysis of the data.  
Since many students have 
multiple FTEs calculated, 
using Excel to sum by student 
will allow the detail to be 
available while providing 
subtotals below each student. 
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Summary

• Basic Excel techniques can be very useful when 
troubleshooting  
• EMIS data in the Student Information System

• EMIS reports

• preview/review files 

• These techniques should be part of your everyday practices
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Resources

• Microsoft Excel Help within Excel “?” Articles and Videos

• Google it 

• Microsoft Excel Classes

• Your ITC
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Questions?


